New PCI Compliance Standards Effective July 1, 2018

In order to meet new PCI Data Security Standards, we at Probill have released a mandatory security update for all PaySimple customers. Probill Software version 2.8.6 has migrated from an earlier version of TLS to a more secure protocol – TLS v 1.2. This update must be installed by all customers running Credit Card and ACH through the software by June 28, 2018 or you will no longer be able to process transactions through Probill.

What is TLS? Transport Layer Security (TLS) is a cryptographic protocol used to establish a secure communication channel between two systems. It authenticates one or both systems, and protects the information passing between the two systems. TLS was standardized by the (IETF) Internet Engineering Taskforce and has undergone several revisions to improve security over the years.

If you have any further questions or concerns about PCI Compliance or Probill version 2.8.6 please feel free to reach out to our technical support line at 1(800)-409-4997.

BACK TO BLOG
Share:

Leave a Reply

Your email address will not be published. Required fields are marked *

Start Your Free Trial Today. It's Fast And Easy!

Fully functional and good for 45 days!

Get In Touch Today

For all questions and inquiries, feel free to get in contact with our friendly team today.